ESP8266 disappointment

I found a very promising new ESP8266 module, from Olimex (a Bulgarian company).

MOD-WIFI-ESP8266-DEV-1

It’s a breadboard-friendly board with an ESP8266 and 512k of flash memory on it, and it’s dead cheap. There’s even a carrier board for it, with a relay and a reset button, also dead cheap. I bought a couple, because it exposes all the pins from the microcontroller, so I can (a) use more than one I/O, and (b) hook up the reset pin so that I can put the device into (and, more importantly, wake it up from) deep sleep mode to extend battery life. There are videos on line of how simple it is to program these devices using the new arduino IDE.

The (insert strong adjective here) problem is that I can’t (insert strong adjective here)-well get it to work. I can connect it up to my PC fine. I can even put it into flash mode perfectly well. In neither case will it respond coherently to anything sent to it from the PC. In ‘normal’ mode, it just repeatedly sends the word ‘Error’ over the serial link, and does not respond to any AT commands.

Olimex ESP8266 errors

In reflashing mode, it simply fails to respond to the reprogramming commands. I’ve tried two of these modules, and both behave the same. I’ve contacted Olimex both by email and on their forum, and had no response. It’s a shame, but I think these modules are destined for the rubbish bin. At least they weren’t expensive.

Update: Olimex have got back to me, and have made some helpful suggestions. They don’t know what the problem is, though, and it’s not one they have seen before. It may well be something to do with my serial adapter. I have another on order, so I guess I’ll find out in due course.

4 thoughts on “ESP8266 disappointment

  1. I have had the same issue and I tracked it down to the CR/LF combination I was sending to the device.
    Depending on the version of the AT firmware it either required a single (CR or LF ) or both.
    Hope this helps, good luck with the modules.

  2. Also the flash is 2MB:
    “Our module comes with installed 2MB of SPI Flash while our competitors modules have just 512KB of SPI Flash”

  3. Hi,

    Yes even I completely agree on ESP8266 board.

    Flashing works and see Green light…and when you connect to system and go to Serial monitor in Arduino IDE pain begins…NOTHING WORKS.

    Its a crap to get started. It not a plug and play board like Arduino.

Leave a Reply

Your email address will not be published. Required fields are marked *